Errores de versiones al instalar Magento 2

Errores de versiones al instalar Magento 2

Uno de los problemas más comunes en la instalación de Magento 2 es la falta de compatibilidad con las versiones de servidor o hosting.

Además de los requerimientos de memoria y procesamiento, es indispensable verificar las versiones instaladas, a continuación los requerimientos mínimos para la instalación o actualización.

Sistema Operativo

Distribuciones Linux como RedHat Enterprise Linux (RHEL), CentOS, Ubuntu, Debian.

Requerimientos de Memoria de servidor

El mínimo recomendado es de 2GB de RAM, si se emplea un sistema con menos memoria es recomendable crear un archivo Swap, de lo contrario la instalación o actualización seguramente fallará.

Servidores Web

Pueden emplearse Apache 2.2. o 2.4 (http://httpd.apache.org/download.cgi) o Nginx 1.0 o posterior (http://nginx.org/en/linux_packages.html)

Bases de datos

MySQL 5.6 (https://www.mysql.com) como base de datos nativa. MariaDB y Percona son compatibles con Magento ya que soportan APIs de MySQL 5.6.

PHP

Las versiones de PHP varían según la versión de Magento:

– 7.0.2, 7.0.6 hasta 7.1 para todas las versiones Magento 2.x

Magento 2.1.x dejó de soportar PHP 5.5 lo que genera la mayoría de errores en las nuevas instalaciones o actualizaciones, en especial en servidores de hosting compartidos.

Extensiones de PHP

Se requiere contar con las siguientes extensiones:

curl
gd, ImageMagick 6.3.7 (or later) or both
intl
mbstring
mcrypt
mhash
openssl
PDO/MySQL
SimpleXML
soap
xml
xsl
zip
PHP OPcache

Finalmente aún cuando es opcional se recomienda contar con php_xdebug2.2.0 (https://xdebug.org/download.php) lo que puede impactar considerablemente el rendimiento.

¿Necesita asesoría para desarrollar o renovar la plataforma eCommerce de su organización? Conozca aquí cómo podemos ayudarle